Our non-scheme payments provider has implemented a fix and PayID services are now operating as normal. We will continue to monitor.
Posted Apr 15, 2026 - 22:21 AEST
Identified
Our non-scheme payments provider has confirmed they are experiencing intermittent issues with PayID services and are currently investigating. There is no impact to payments.
A further update will be provided when available.
Posted Apr 15, 2026 - 20:23 AEST
Investigating
We are currently investigating an issue affecting the lookup of PayID information for some accounts.